Degraded Performance to Calendar and Other Pages

Incident Report for Dash by DaySmart

Resolved

This incident has been resolved.
Posted May 20, 2026 - 10:09 PDT

Identified

The engineering team has identified that there was an regional CDN issue causing degraded performance to some areas of the application.
Posted May 20, 2026 - 10:09 PDT

Investigating

We are currently investigating this issue.
Posted May 20, 2026 - 09:58 PDT
This incident affected: Dash Application.