The performance slowdown due to the massive registration has recovered.
This incident is now resolved.
Posted Jan 21, 2026 - 09:19 PST
Monitoring
We are monitoring the slowness due to a large registration and are seeing improvements.
We are actively monitoring the platform to ensure performance remains stable and will confirm full resolution once sustained recovery is verified.
Posted Jan 21, 2026 - 09:16 PST
Identified
We have identified the root cause of the degraded performance affecting the Dash application, a large registration event. Elevated latency is contributing to slower page load times and intermittent interruptions, including pages timing out or failing to load.
Our engineering team is actively working on remediation steps to restore normal performance and reliability. This incident remains a top priority, and we will provide another update as remediation progresses.
Posted Jan 21, 2026 - 09:10 PST
Investigating
We are currently investigating reports of slow performance in the Dash application. Customers may experience longer page load times when logging in and navigating between pages. In some cases, there may be intermittent interruptions to service, including pages failing to load or timing out.
Our engineering and operations teams are actively working to identify the root cause and restore normal performance and reliability. We will provide the next update as soon as more information becomes available. Our team is treating this as a top-priority incident and is actively working to identify the root cause and implement a fix.
We apologize for the disruption and appreciate your patience while we work to resolve this issue.
Posted Jan 21, 2026 - 09:05 PST
This incident affected: Dash Application and Dash Database.